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1. GENERAL INFORMATION 

1.1. Introduction 

Free cooling is an economical method used to reduce the energy consumed by the cooling 

systems When outside temperature is lower then inside temperature, the system utilizes the cool 

outside air as a free cooling source. It must hereby be operated and maintained by trained technicians 

according to the safety procedures. 

1.2. Scope 

This manual describes the requirements and procedures to be used during the installation and 

operation of Baran Technology free cooling systems. Read all instructions carefully before any 

installation or operation of Baran Technology Free Cooling System.  

1.3. Related Publications 

Publication Name Publication Number 

 

FCS Fan Box Installation Procedures BR-00001 

FCS Control Unit Installation Procedures BR-00002 

FCS Free Cooling Firmware BR-00003 

  

1.4. Important Safety Infomations 

This manual contains important instructions that should be strickly followed during installation 

and operation of the Free Cooling System. This product is designed for Commercial/Industrial use only. 

If you have any questions regarding safety standards for this product, please contact: 

 

Baran Electronic Systems 

Office Phone:   +90 216 466 88 02 

Customer Service:  +90 216 466 88 03 

E-mail:   info@baran.tech 

Website:  www.baran.tech 

 

1.4.1. Voltage Warning 

 

 

DANGER 
Lethal voltages may be present within this unit even when it does not appear to be 
operational.  Observe all cautions and warnings in this document.  Failure to do so 
may result in serious injury or death. 

 

To make the connection of control unit can present a risk of electrical shock and high short-circuit 

current.  The following precautions should be observed when working on fan cabinet and control unit 

Remove watches, rings and other metal objects. 

Use tools with insulated handles. 
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1.4.2. Site Conditions Caution 

 

 

CAUTION 
Conditions at the installation place may impact the safety of personnel and the 
performance of this product.  Adhere to all manufacturer guidelines. If you have any 
questions regarding the site requirements for this product, please contact Baran 
Electronic Systems Customer Service. 

 

Operate the control unit an inside or enclosed environment only in an ambient temperature 

range  of   -20°C to 60°C. Install it in a clean environment, free from conductive contaminates, moisture, 

flammable liquids, gases and corrosive substances.  

This control unit is designed for use on a properly grounded (earthed) supply and is to be installed 

and operated by qualified personnel. 

1.4.3. Personnel Warnings 

Persons installing, operating or exposed to the Free Cooling System should be aware of the 

following potential hazards. 

 

DANGER—SHOCK HAZARD 
Do not touch un-insulated mains connectors or terminals. 

 

CAUTION—HEAVY 
Fan cabinets weigh up to 90 kg. 

 

IMPORTANT 
Follow manufacturer’s published instructions when installing 

 

1.4.4. Personnel Requirements and Trainings  

This free cooling system should only be installed and operated by qualified personnel.  

The following trainings are recommended for persons will install and operate the Free Cooling 

System. It is the responsibility of the customer, installer and/or operator to provide training consistent 

with local laws and standards. Different companies and jurisdictions may use different names and 

standards for training. Please consult Baran Electronic Systems with any questions about installer or 

operator requirements. 

Trainnings Required for Installation and Operation of Free Cooling 

- Qualified electrical safety and ARC/flash training 

- Lock out/tag out (LOTO) 

- Personal protective equipment (PPE) 

- Ergonomics/proper lifting training 

- Qualified lifting equipment operator training 

 

All personnel installing and operating the Free Cooling must have completed the above trainings.  

Follow local laws and policies regarding additional training requirements.  
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1.4.5. Abbreviations 

 

FCS Free Cooling System 

  

FCCU (FCCM) Free Cooling Control Unit (Free Cooling Control Module) 

FCU Free Cooling Control Unit (Free Cooling Control Module) 

Control Unit Free Cooling Control Unit (Free Cooling Control Module) 

Controller Free Cooling Control Unit (Free Cooling Control Module) 

  

ACCM Air Conditioner Control Module 

ACM Air Conditioner Control Module 

∆T Delta T, Temperature Difference 

A/C Air Conditioner  

A/Cs Air Conditioners 

 

 

 

2. FREE COOLING SYSTEM 

This User Manual is based on standart free cooling system 

Free Cooling System is an energy-saving system which is designed for indoor areas. Indoor  places 

are almost cooled by air conditioner(A/C). Free Cooling Systems provides cool outside air to cool inside 

in lower temperatures by a fan which consumes less energy then AC. To ensure that, the outside 

temperature must be sufficient to cool inside.  Cooler air is transferred from outside to inside through 

a filter. If cooling by fan will not be sufficient or proper then  system activates the A/C units. The 

excellent software algorithm ensures fan, A/C or both to operate stable thus  efficiency and energy 

saving rise maximum levels. 

 

Fan speed is controlled by the difference of inside and outside temperature (ΔT). If ΔT increases, 

fan speed increases proportionally, too.  

2.1. System Operation Algorithm 

System Operation Algorithm is shown in scheme 1. The values in both ends of the arrows are 

adjustable. These adjustable values define the Start/Stop temperatures of the fan, heater and A/Cs.  

 System operation is based on the fact that if the outside air temperature is cool enough to cool 

inside, then it will be profitable to use a fan instead of air conditioner. But the important thing here is 

the control mechanism that always observes the environmental conditions and decides how to 

manage. 



FCS Free Cooling System User Manual 

Baran Elektronik Sistemleri San. ve Tic. Ltd. Sti. 

8 

  

Scheme 1 : Free cooling system operation principle 

 

There are two standard algorithms. Inside and outside temperature related  algorithms. 

 The first one, the inside temperature related  algorithm is the main one. This also includes a 

mixed mode (emergency mode) algorithm as an option. The second one is the outside temperature 

related algorithm and is an option for the user. 

 The operation of the system could be explained generally as follows. 

2.1.1. Main (Strandard) Free Cooling Algorithm : Inside Temperature Related Algorithm 

The algorithm of this feature could be explained as follows which a general flow diagram could 

seen in the Scheme 2 

1. If inside temperature is very low, the controller operates the heater and when it reaches the 

set value, controller shuts down the heater. 

2. If inside temperature exceeds the room temperature value, then controller operates fan.  
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At this point, this also needs the environmental conditions to be provided. If the environmental 

conditions are not provided the controller does not operate fan, waits until the inside temperature 

reaches A/C1 TURN ON temperature. 

  

Proportional Fan Speed Control  

 

Fan operates between a limit that it can be efficient. And the fan speed is adjusted according 

to the environmental conditions. 

i. If inside temperature is a small amount above the threshold (FAN TURN ON) level ( 

and the outside temperature is cooler), the controller operates fan very slow. 

ii. If inside temperature is big amount above the threshold (FAN TURN ON) level ( and 

the outside temperature is cooler), the controller operates fan very fast. 

3. After operating fan, if inside temperature keeps rising  and reaches to (FAN TURN OFF) 

temperature then  controller shuts fan down  

4. If inside temperature reaches to the turn on point of air conditioner 1 ( A/C 1 TURN ON ), 

control unit starts A/C 1. 

5. If inside temperature still keeps rising and reaches to the turn on point of air conditioner 2 

(A/C 1 TURN ON Temp + ” A/C 2 Turn ON/OFF Difference from A/C 1” ) then controller starts 

air conditioner 2 (A/C2), too 

 

a. Inside Temperature Starts to Decrease, 

 

- If inside temperature decreases and falls below  “air conditioner 2 (A/C2) turn off 

temperature “ value (A/C 1 TURN OFF Temp + ” A/C 2 Turn ON/OFF Difference from A/C 

1” ), it shuts air conditioner 2 (A/C2) down. 

- If inside temperature keeps decreasing and falls below  “air conditioner 1 (A/C1) turn off 

temperature “ value (A/C 1 TURN OFF), it shuts air conditioner 1 (A/C1) down. 

 

b. Inside Temperature Keeps Increasing, Mixed Mode (Emergency Mode, A/C1, A/C2, Fan) 

- If inside temperature increases and reaches to  (Mixed) “Mode Starting Temperature ( 

Emergency Mode) the Mixed Mode is enabled (ON), then system also starts fan  to operate 

with A/C1 and A/C2. The fan is started  in addition to the still operating A/Cs 

- If inside temperature starts to decrease, the system first shuts down fan at ((Mixed 

Mode)  “ Fan Turn OFF Temperature” 

- If inside temperature keeps decreasing, system shuts down A/C2 at ((Mixed Mode) A/C 

TURN OFF Temperature + ” A/C 2 Turn ON/OFF Difference from A/C 1”) value . 

- If inside temperature keeps decreasing, system shuts down A/C1 at ( ((Mixed Mode) A/C 

TURN OFF Temperature)  value. 
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Scheme 2 : Inside Temperature Related Algorithm   
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2.1.2. Outside Temperature Related Algorithm 

The algorithm of this optional feature could be explained as follows which a general flow 

diagram could seen in the Scheme 3 

 If this option is selected (enabled); 

While the system is operating on  Main Free Cooling Algorithm ( Inside Temperature Related 

Algorithm), if the outside temperature exceeds the temperature adjusted in “Air Conditioner” tab  in 

““If Outside Temperature is higher than ….. switch to A/C automatically”  ” command then system 

automatically switches to Air conditioners. The A/Cs operate until the outside temperature decreases 

0.5 0C below this temperature. This feature is developped to avoid numerous numbers of short time 

switchings of fan and A/Cs in middays. This also prevents high loading of energy lines, early aging of 

the devices and to be broken frequently. 
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Scheme 3 : Outside Temperature Related Algorithm 
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2.1.3. Free Cooling System General Structure 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Scheme 4 : Free Cooling System General Structure 
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2.1.4. Control Unit Connection Ports 

 

Scheme 5. Connection Ports 
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3. PARTS OF FREE COOLING SYSTEM 

3.1. Free Cooling Control Unit ( Free Cooling Control Module, FCU) 

Free Cooling Control Unit is the main controller. The datas coming from the sensors and 

peripherals are evaluated by microprocessor in control unit and the commands are sent for the 

operation. 

The operation parameters could be adjusted  by using buttons on controller as well as via 

Graphical User Interface (GUI) or web interface. 

The power consumption of the controller is lower then 8 W and the number of the air 

conditioner control modules could be connected is 2. 

For more details refer to datasheet. 

 

 

3.1.1. LCD Display and Buttons 

 

 

ESC KEY 
If user uses that button when the display is on main screen, system opens return to 
default menu. System can be returned to default by using the right button 
combination. 

 

ENTER KEY 
If user uses that button when the display is on main screen, system opens settings 
menu. 

 

UP KEY 
If user uses that button when the display is on main screen, system logs will be 
deleted after the password is entered. 

 

DOWN KEY 
If user uses that button when the display is on main screen, system logs will be 
deleted after the password is entered. 

 

 

Password 

The default password is 2009. 

User can enter the password by using UP, DOWN and ENT buttons  as shown in scheme 6. 
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Scheme 6. The LCD Operation Map 
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3.2. Air Conditioner Control Module (ACCM, ACM) 

Air conditioner control module is used to control both split type and DX type air conditioners 

by the control unit. 

 

3.2.1. Controlling of Split Type Air Conditioners : 

Split type air conditioners are generally medium power consuming devices (compared to DX 

High Power A/Cs) thus it they can be controlled over the mains. ACCM controls split type air 

conditioners by switching its relay connected in series to mains of split type A/Cs.  

 

3.2.2. Controlling of DX Type (High Power-High Precision) Air Conditioners : 

DX type air conditioners are special designed and high power consuming devices. That’s why 

it is not correct to turn ON/OFF them over the mains. Each device has different turn ON/OFF 

procedures. For to turn ON/OFF these devices externally, the local/remote input of the control card of 

DX A/Cs is triggered(activated) by any of the X1, X2 and X3 (dry contact) outputs of ACCM. By activating 

this input, the DX  air conditioner’s controller turns ON/OFF internally. 
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3.3. I/O (Input/Output) Cards 

3.3.1. Input Card 

Input card is used to add extra alarms to standart FCS . If any of the inputs of the card receives 

a signal from any sensor (such as fire sensor, smoke sensor, leakage sensor, PIR detector…etc), FCS 

executes some operations related to this input’s defined task. 

 The details of the operation of the card are explained below (Table 1). 

1. Input card has 16 inputs. 

2. 4 of the 16 inputs are fixed(predefined by the manufacturer) inputs. 

3. Remainin 12 inputs are free to user’s disposal. Any kind of sensor with a dry contact output 

could be connected here such as fire sensor, smoke sensor, leakage sensor, PIR detector…etc. 

4. If a signal is received in any of the fixed inputs, FCS sends alarm signal on GUI on the screen, 

sends SNMP Trap and executes the predefined tasks. 

5. If a signal is received in any of the free inputs, FCS sends alarm signal on GUI on the screen, 

sends SNMP Trap .  But DOES NOT EXECUTE any task. This feature is not available for the free 

inputs. 

 FEATURE ACTION TAKEN 

Input Status Description 
Rename 

on 
GUI 

Alarm 
on 

GUI 

SNMP 
Trap 
(*) 

Operation 

General 
Alarm 

Output(*) 
(250 V/1 A) 

1 Fixed 
Fire Alarm 

Level 1 
No Yes Yes Fan OFF Yes 

2 Fixed 
Water/Leakage 

Alarm 
No Yes Yes Fan OFF Yes 

3 Fixed Dust Alarm No Yes Yes Fan OFF Yes 

4 Fixed 
Knock (Vibration) 

Alarm 
No Yes Yes Fan OFF Yes 

5 Free Free Yes Yes Yes No No 

6 Free Free Yes Yes Yes No No 

7 Free Free Yes Yes Yes No No 

8 Free Free Yes Yes Yes No No 

9 Free Free Yes Yes Yes No No 

10 Free Free Yes Yes Yes No No 

11 Free Free Yes Yes Yes No No 

12 Free Free Yes Yes Yes No No 

13 Free Free Yes Yes Yes No No 

14 Free Free Yes Yes Yes No No 

15 Free Free Yes Yes Yes No No 

16 Fixed 
Fire Alarm 

Level 2 
No Yes Yes 

Fan OFF 
A/C OFF 

Yes 

 

Table 1.  Input Card’s Technical Features 

* “However SNMP Trap” and “General Alarm”  are standart features of FCS, it is written here 

to explain scenarios. 

** “ Free” means, user may  define and use. 
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3.3.2. Output Card  

 Output card is used to activate (ON/OFF) any device remotely by clicking on the GUI. 

 The details of the operation of the card are explained below. 

1. Output card has 16 outputs. 

2. By clicking the output on the GUI, FCS opens/closes the micro switch related to that output. 

3. Outputs are microswitches and could be loaded max. 60V/500 ma. 

4. If user wants to switch a high load device, then there must be used a drive unit such as relay, 

contactor to switch the desired device. 

 

 FEATURE ACTION TAKEN 

Output Status Description 
Rename 

on 
GUI 

Max.Load 
(Vmax/Imax) 

Info 
on 

GUI 

Activate 
Output 

(ON/OFF) 
(Dry Contact) 

1 Free Free Yes 60V/500ma Yes Yes 

2 Free Free Yes 60V/500ma Yes Yes 

3 Free Free Yes 60V/500ma Yes Yes 

4 Free Free Yes 60V/500ma Yes Yes 

5 Free Free Yes 60V/500ma Yes Yes 

6 Free Free Yes 60V/500ma Yes Yes 

7 Free Free Yes 60V/500ma Yes Yes 

8 Free Free Yes 60V/500ma Yes Yes 

9 Free Free Yes 60V/500ma Yes Yes 

10 Free Free Yes 60V/500ma Yes Yes 

11 Free Free Yes 60V/500ma Yes Yes 

12 Free Free Yes 60V/500ma Yes Yes 

13 Free Free Yes 60V/500ma Yes Yes 

14 Free Free Yes 60V/500ma Yes Yes 

15 Free Free Yes 60V/500ma Yes Yes 

16 Free Free Yes 60V/500ma Yes Yes 

 

Table 2.  Output Card’s Technical Features 

* “ Free” means, user may  define and use. 

 

3.3.3. Alarm Card 

 Alarm card is used to activate the related output (as dry contact) of the card  if any alarm exits 

on FCS’s own peripherals (sensors). The general output on control unit does not deliver the ID of the 

alarm. But alarm card has individual outputs for each alarm.  

 The details of the operation of the card are explained below. 

1. Alarm card has 16 outputs. 

2. All outputs are predefined by the manufacturer. They can not be changed. 

3. If any alarm exits, FCS sends alarm signal on GUI on the screen and sends SNMP Trap. 
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4. Besides item 3, FCS also activates the related output switch (as dry contact)  of the alarm card. 

5. Outputs are microswitches and could be loaded max. 60V/500 ma. 

6. Alarm card and output card are the basicly the  same cards, J1 defines for which purpose it will 

be used. 

 

 FEATURE ACTION TAKEN 

Output Status Description 
Rename 

on 
GUI 

Max.Load 
(Vmax/Imax) 

Alarm 
on 

GUI 

SNMP 
Trap 
(*) 

Activate 
Output 

(ON/OFF) 
(Dry 

Contact) 

General 
Alarm 

Output(*) 
(250 V/1 A) 

1 Fixed High Temperature No 60V/500ma Yes Yes Yes Yes 

2 Fixed Low Temperature No 60V/500ma Yes Yes Yes Yes 

3 Fixed High Volt No 60V/500ma Yes Yes Yes Yes 

4 Fixed Low Volt No 60V/500ma Yes Yes Yes Yes 

5 Fixed A/C Phase  Power 1 No 60V/500ma Yes Yes Yes Yes 

6 Fixed 
Maximum 
Humidity 

No 60V/500ma Yes Yes Yes Yes 

7 Fixed Dew Point No 60V/500ma Yes Yes Yes Yes 

8 Fixed Filter Block No 60V/500ma Yes Yes Yes Yes 

9 Fixed Poor Heating No 60V/500ma Yes Yes Yes Yes 

10 Fixed Poor Cooling No 60V/500ma Yes Yes Yes Yes 

11 Fixed Fan Power No 60V/500ma Yes Yes Yes Yes 

12 Fixed Fan RPM No 60V/500ma Yes Yes Yes Yes 

13 Fixed A/C Phase  Power 2 No 60V/500ma Yes Yes Yes Yes 

14 Fixed Fire Alarm No 60V/500ma Yes Yes Yes Yes 

15 Fixed 
Very High 

Temperature 
No 60V/500ma Yes Yes Yes Yes 

16 Fixed Free Cooling OFF No 60V/500ma Yes Yes Yes Yes 

 

Table 3.  Alarm Card’s Technical Features 

* “However SNMP Trap” and “General Alarm”  are standart features of FCS, it is written here to explain 

scenarios. 

3.4. Fan Box 

Fan box is the metal cabin with fan inside  used for transfering, filtering and directing the air. 

While transferring the air, also changing  direction and level of the air flow is done. The low 

insertion loss centifugal fans are used for transferring the air. The fan boxes are designed according to 

the type of the centrifugal fan. However centrifugal fans have a very common use, axiel fans are used 

for some special solutions. 

There are two different types of fan boxes related to the installation location. The indoor 

model, fan box is placed inside the room(shelter) and outdoor model, fan box is placed outside the 

room(shelter) 
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Indoor Type 

 

Outdoor Type 
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3.5. Filter 

In fan boxes two types of filters are used for filtering the air from dust, leaves, flies, 

particles..etc. However it can be designed in different standards for different projects but generally 

the first filter is the rough(the first) filter (G2) which receives the air first. The other filter is the fine 

(the second) filter (G3). 

Rough Filter (G2) : It is located on the entrance of the air inlet of  fan box and receives the air 

first. These filters are in G2 standard and keeps flies, bugs, leaves..etc. They also have a strong dust 

keeping capability. 

They also have low  insertion loss causing very low air pressure decrease in the flow path. 

Fine Filter (G3) : These filters are the second filter receiveing the air after the first filter. It is 

designed in G3 standard and keeps fine dusts and particles which passes the first filter. These filters 

also have  low  insertion loss causing very low air pressure decrease in the flow path. 

The best feature of these filters is that the fibers are changable. 

 

 

The fiber can be changed by seperating two interlaced wings after unscrewing the screws 

located on the corners of the frame. 
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3.6. Sensors 

3.6.1. Inside Temperature and Humidity Sensor 

This sensor detects and measures the temperature and humidity of the place to be cooled.To 

locate the sensor in the correct location is very important for the accuracy of the datas. Refer to the 

installation manual  for the location and the datasheet for technical information. 

3.6.2. Outside Temperature Sensor  

This sensor detects and measures the temperature of the outside from where the air is taken 

and blowed inside. To locate the sensor in the correct location is very important for the accuracy of 

the datas. Refer to the installation manual  for the location and the datasheet for technical information. 

3.6.3. Digital Differential Pressure Sensor 

 This sensor compares the pressure difference of air before before and after the filter. This 

digital sensor sends the pressure difference data real time to the control unit. Refer to the installation 

manual  for the location and the datasheet for technical information. 

3.6.4. Analog Pressure Switch  

 This is a mechanical switch delivers an alarm signal if the pre-adjusted contacts (threshold 

level) are contacted related to the decrease in air pressure. Refer to the installation manual  for the 

location and the datasheet for technical information. 

3.6.5. Water Float Sensor 

This sensor is used in high fan power models and is used to prevent the rain drops&particles 

to go inside. It sends alarm signal if raindops go inside while the fan is operating. 

3.7. Fans 

There are different types of fans used in free cooling systems such as AC or DC voltage  supplied 

fans, centrifugal or axiel fans. 

In the beginning the free cooling systems are developped  for telecommunication 

infrastructure. The power supply in telecommunication infrastructure is 24 VDC or -48 VDC. So the free 

cooling systems were designed to be supplied by 24 VDC or -48 VDC. After expanding the usage sectors 

of FCS, high power fans needed and so the AC fans.  

Also first demand was for low power and  single axis flow thats why the first models were 

developped on DC motors and axial fans. Later on, following expansion of the demand, high power 

and flow level change were needed. So centrifugal fans started to be used. 
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3.8. Panel Board (Optional) 

Panel Board is the panel board that free cooling control unit, air conditioner control module(s) 

are placed in and all cablings are centered.  
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4. GRAPHICAL USER INTERFACE (GUI) / SOFTWARE  

4.1 PC Installation 

Installation CD is available in the control unit packet. User can install the software by this CD. 

Installation stages; 

FCS v4 Free Cooling Viewer Setup\setup.exe 

Next 

 

User should choose the folder for installation and then clicks Next; 
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4.2 PC Uninstallation  

 

User should run the Free Cooling Viewer to uninstall the program. 

All saved data still stays in the system after uninstalling. 

 “FCSv4 Free Cooling Viewer v1.0” is a 3.party Windows application that user can easily achieve to 

manage the FCS system from PC with an interface by using one of the USB, RS232 or Ethernet 

Connection. 

Free Cooling Viewer has ability to; 

remote reel time chasing and graphically monitoring 

show, change and reset the operating parameters 

enable/disable keypad  

restart FCS and air-conditioning units  

switch FCS to bypass mode 

erase data from memory 

download data as Excel file.   

(fan & air-conditioning operating times, temperature curves..) 

4.3 Internet Connection With Ethernet 
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After launching Free Cooling Viewer, Tools > Communication Configuration > Connection Type > 

Ethernet Gateway is selected. Then user can determine the values to communicate with FCS unit and 

apply this settings by using Connection Test button. After applying the settings, these settings can be 

saved by using Ok button. 

4.4 Connection With USB 

 

 

After launching Free Cooling Viewer, Tools > Communication Configuration > Connection Type > 

Modbus RTU (RS485/RS232/USB) is selected. Then user can determine the values to communicate 

with FCS unit and apply this settings by using Connection Test button. After applying the settings, these 

settings can be saved by using Ok button. 

4.5 Parameters Setting & Menu 
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Device control settings can be managed by using this layer. These settings are given below:  

4.5.1 Real Time Monitor 

 

The screening of the incoming datas is selected whether by “text monitor” or “ graph monitor”. 

 

4.5.1.1 Text Monitor 

User can monitor the real time data about the station as a flowing list by using this option. 

 

4.5.1.2 Graph Monitor 

User can observe real time  on a graphic by using this option.   
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4.5.2 View 

4.5.2.1 Show All External Plag and Play Cards 

 

Alarm Card 

The current situation of the alarm card is  monitored. 

 

 

(See also   Section 3.3.3) 

 

 

 

Input Card 

The current situation of the input card is  monitored and the following processes could be executed. 
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1. File > Import contacts name table; all user-defined input names can be loaded from a saved 

file.   

2. File > Export contacts name table; all user-defined input names can be transferred to external 

storage devices, PC etc. 

3. Edit > Replace name; all inputs can be renamed by user. 

 

 

(See also   Section 3.3.1) 

 

 

 

 

 

 

Output Card  

 

File > Output Control Card (Optional): User can monitor the current situation about the output control 

card and also can change these outputs. 
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File > Import contacts name table; all user-defined input names can be loaded from a saved file.   

File > Export contacts name table; all user-defined input names can be transferred to external storage 

devices, PC etc. 

Edit > Replace name; all inputs can be renamed by user. 

 

(See also   Section 3.3.2) 

 

 

4.5.2.2 Show / HIde Opr.Mode Alarms Status of PerIpherals 

 

The feature to select “Operation Mode, Alarms and Status of Peripherals” to be secreened in visual 

forms on the right side of the screen. 
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4.5.2.3 Show / Hide Gauge Panel 

 

 The feature to select the important  parameters to be screened in visual meter forms  at the bottom 

of the screen. 

. 

 

 

 

4.5.2.4 View > Show Power Analyser Screen   

  

 This feature is designed to place a power meter analyser to FCS and check the power and 

related parameters. The reference meter is Eastron SDM630 model power analyser. The following 

shows if FCS is Active or Passive. 

shows all occured alarms. All 

alarms are optional. If user 

doesn’t want to see some of 

them, they can be disabled. 

 

shows all active/passive status of 

peripherals. 

shows number of error sensors 

and power supply 
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parameters could be read by connecting the power analyser in series to the circuit  and  RS485 Port 

modbus RTU  to the RS485 input of the main board 

Power Factor (PF) 

Total System Power (kWh) 

Total System Volt Ampere Reactive  Inductive (Var) 

Total System Volt Ampere Reactive  Capacitive (Var) 

 

4.5.2.5 Show / Hide Site List 

 

  The feature to select  the saved “site names ” to be screened on the left side of the screen. It ensures 

to acces sites easily. In the side list section, by pressing Add/Edit button, a new site parameters and 

the site name could be registered by proceeding “ Adding Manual Devices” button. 
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4.5.3. Logs&Graph Menu 

 

4.5.3.1 Download Event Log Export MS Excel 

The event logs could be downloaded (as of that moment) to the computer as MS Excel file. As well as 

saving the file into “C:\Baran Technology\Free Cooling Viewer v4.6\LOG - EVENT_ALARMS” directory, 

it also opens the file on the desktop 

 

4.5.3.2 Download Total Operation Time of Fan and Air Conditioner Export MS Excel 

The “Total Operation Time of Fan and Air Conditioner” logs could be downloaded (as of that moment) 

to the computer as MS Excel file. As well as saving the file into “C:\Baran Technology\Free Cooling 

Viewer v4.6\LOG - OPERATING_TIME” directory, it also opens the file on the desktop 
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Downloading and Reporting data;  

Download data from storage                                                            Report downloaded data as Excel file 

 

 

4.5.4 Device Parameters 

 

 

 

 

4.5.4.1 New Parameters; 

 

i. Import & Export Datas 

The datas which are in appropriate format could be imported in the “New Parameters” Section 

as well as the datas in  “New Parameters” Section could be exported in the same format. 

 
 

 

ii. Send All Parameters to FCS 
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The new parameter(s) could be saved in the microprocessor by “  Send All Parameters to FCS“ 

button. 

 

 

* For the remaining parameters description and settings, please refer to Section 4.6.2  (The Settings of 

FCS) 

4.5.4.2 View Parameters 

 The valid parameters, status of alarms and devices could be viewed in this section. 

 

 

4.5.4.3 Restore Default Parameters;   

 

Every FCS is set to factory settings before testing. These setting values are studied at R&D Department 

according to the average statistics of the that country/region. After installation, there might be fine 

tuning for that location. If any problem occcurs that user can not adjust the setting, then this feature 

ensures the factory settings to be adjusted. Factory settings will operate the FCS appropriately until a 

technician reaches and makes the fine tuning. 
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4.5.5 Tools  

 

Tools > Back To Normal Operation of FCS  : After starting air conditioners or fan manualy for any 

reason, this feature puts FCS in previous conditions before manual start 

Tools > Manual Start ACs : This feature provides the user to check remotely if the ACs operate or not 

(independent from the system). 

Tools > Manual Start Fans      This feature provides to start Fan(s) manually. 

Tools > Clear Instant Alarms: This feature is used clear instant alarms seen on the right side of the 

screen. 

Tools > Restart Device: Provides restarting the FCS Control unit remotely. 

Tools > Clear Device Memory; All data in FCSv4 memory can be deleted. 

Tools > Restart ACs    This feature is used to reset (only split models) ACs. From time to time, the split 

A/C models get stuck and needs to reset. The controller interrupts the mains of the ACs for 15 sec. 

then  operates again. 

Lock Device Keyboard; FCSv4 keyboard  can enable/disable. Thus, System parameters are prevented 

to change by unauthorized persons on the field. (This option only can be used through the USB 

connection.) 

Service; Service settings of FCSv4 is accessible with this option. Service settings are given on the right 

side; 

 

FCSv4 operation system can be optimized according to sensor placements. 
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FCSv4 contacts (NC/NO), which controls the air-conditioning units, can be optimized according to 

system operation. 

 

FCSv4 contacts, which controls heaters, can be optimized as air-conditioning unit or heater. 

Tools > Service > Change Contacts Status  

Tools > Service > Test FC’s Routines :  This option is used to check if the controller operates well 

independent of peripherals (sensors). 

Tools > Service > RS485 Self Test 

Communication Configure; “Access point settings” are configured which will provide to connect to the 

FCSv4 control unit. This connecition can be made through two different points. Ethernet Gateway and 

Modebus RTU. 

4.5.6 Clear List 

Selecting this command clears the datas on the “Text Monitor” mode. 

4.5.7 Log in 

 

Log in; User can access the system as admin. As an admin, user can; 

Reset the FCSv4  

Delete all data in FCSv4 memory 

Change parameters 
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7.7. FCS MODBUS CONFIG FCS Modbus Config 

Device addr: It’s the part that user defines the Modbus address. It can be between 1 – 247. 

Baudrate: Communication speed of Modbus is adjusted from here. Baudrate intervals are 4800, 9600, 

19200, 38400, 57600, 115200, 230400, 460800. 

Connection: If device communication will not be form USB connector, it should be defined from here.  

External communication ports; GPRS, RS485, Ethernet. 

NMS time (Minute): On this screen user can define how often the system is set to send data to the 

device management system. 

4.6 Parameters Descriptions and Settings  

User can access the parameters by pressing ENT button when it’s on the main screen. FCS operation 

parameters are defined here. 

Alarms 

 

 

LOW TEMPERATURE ALARM 
If inside temperature is lower than the set value (*), system creates this alarm. 
*Device Parameters > New Parameters > Alarms > Low Temp. Alarm Threshold 
 

 

HIGH TEMPERATURE ALARM 
If inside temperature is higher than the set value (*), system creates this alarm. 
*Device Parameters > New Parameters > Alarms > High Temp. Alarm Threshold 
 

 

VERY HIGH TEMPERATURE ALARM 
If inside temperature is higher than the (second) set value (*), system creates this 
alarm. 
*Device Parameters > New Parameters > Alarms > Very HighTemp. Alarm Threshold 
 

 

DEW POINT ALARM 
Dew point is calculated according to the instant temperature and humidity values. 
If this calculation results a dew point, then system creates this alarm. 

 

MAXIMUM HUMIDITY ALARM 
If inside humidity value is higher than the set value (*), system creates this alarm. 
* Device Parameters > New Parameters > Alarms > Max. Humidity 
 

 

POOR COOLING ALARM 
If A/C  can’t decrease inside temperature ( at the end of first 60 minutes of operation 
) below than it has started, system creates this alarm. 

 

POOR HEATING ALARM 
If heater can’t increase inside temperature ( at the end of first 60 minutes of 
operation ) above than it has started, system creates this alarm 

 

FAN SPEED (RPM) ALARM 
If fan speed is not at the appropriate level related to the set value (*),system creates 
this alarm 
* Device Parameters > New Parameters > Alarms > Max. Humidity 

% 
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FAN POWER ALARM 
If the conditions for fan to operate are present but fan does not run for any reason, 
system creates this alarm (eg. connection, fan’s fuse damaged..) 

 

FILTER PRESSURE ALARM 
If  filter pressure is higher than the set value (*), system creates this alarm  
* For digital differential pressure sensor : Device Parameters > New Parameters > 
Alarms > Filter Pressure Alarm Threshold 
* For analog pressure switch : Adjusted as mechanicaly default at the factory. 

 

LOW BATTERY ALARM 
If the voltage of the batteries is lower than the set voltage value (*), system creates 
this alarm. 
*Device Parameters > New Parameters > Alarms > Low Battery Alarm Threshold 
 

 

HIGH BATTERY ALARM 
If the voltage of the batteries is higher than the set voltage value (*), system creates 
this alarm. 
*Device Parameters > New Parameters > Alarms > High Battery Alarm Threshold 
 

 

A/C PHASE POWER 1 ALARM 
If there is no Mains on air conditioner control module 1, system creates this alarm. 

 

A/C Phase Power 2 Alarm  
If there is no Mains on air conditioner control module 2, system creates this alarm. 

 

FCS OFF ALARM 
If there are sensor failures or if the device is on maintenance mode, system creates 
this alarm. . In case of this alarm occured, Fee Cooling System turns off itself and 
A/C units swtitch on the air conditioners.  
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4.6.2 The Settings of FCS (Listed as in the GUI menu order) 
 

No Parameter Status Unit Default 
Version s4.2, h1.2 

Description or Earlier Later 

Min. Max. Min. Max. 

 Device Parameters > New Parameters > Air Conditioner        

1 A/C delay protection 

 

 

 

 

 

 

 s 300 0 300 0 300 In case of frequent power 

interruption, compressor is 

disabled during the set time and 

thus sytem protects A/C.  

 2 A/C minimum operating voltage  V 120 0 120 0 120 System shuts down A/C if mains 

falls below this voltage thus 

protects A/C. Minimum operating 

voltage is adjusted according to 

A/C features. 

3 A/C maximum operating voltage  V 245   220 270 System shuts down A/C if mains 

exceeds this voltage thus protects 

A/C. Maximum operating voltage is 

adjusted according to A/C features 

4 Forced A/C mode operation ON Min. 15 0 180 0 180 This feature is a “ user defined “ 

version of the following feature 

“A/C minimum operation time for 

8 minutes” 
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5 A/C minimum operation time for 8 

minutes 

ON / OFF  OFF ✓ ✓ If A/C starts up after any event, 

system does not interrupt  A/C’s 

operation for next 8 minutes. 

 6 Turn off if A/C if it opr. poor ON / OFF  OFF 

 

 

 

 

 

✓ ✓ If cooling performance of A/C is 

unsatisfactory , system shuts down 

A/C to save the energy. 

 7 Turn on A/C mix outdoor temp. ON °C 25 18 32 18 36 If outside temperature exceeds the 

setpoint, Free Cooling mode is 

disabled and A/C starts .  

8 A/C turn on temperature  °C 28 24 32 22 38 The temperature value that A/C 

will start to operate. If Free Cooling 

will not be able to cool the room 

and the temperature reaches this 

set value, then A/C starts to run. 

9 A/C turn off temperature  °C 24 18 26 20 36 After A/C has started to cool, if   

inside temperature falls to this set 

value then A/C stops. 

10 Run A/C’s, if No AC phase ON / OFF  OFF  ✓ If there is no mains, the system 

switches the A/Cs ON 
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11 A/C1 – A/C2 Delta temperature (1)  °C 5  1 10 This is the temperature difference 

between the start (ON) 

temperature of  A/C1 and A/C2. 

This means that the start 

temperature of A/C2 is the start 

temperature of A/C1 +  (∆t)  

12 

 

 

Switch the A/C using timing (1) 

 

 

 

ON / OFF Min. 120  120 240 This feature is used to operate the 

A/Cs in a shift work. A/C1 operates 

during the adjusted time then 

switches to A/C2. After the same 

duration the system switches to 

A/C1 again 

If both A/Cs exceed the settime on 

continuous operation , the system 

switches A/C units from active to 

passive. This feature ensures A/Cs 

operate equally and stable. 
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Start fan (in this case both fan A/C 

operates together) 

 

       The indoor-outdoor delta 

temperature  value if FCS operates 

in mix mode  

 Device Parameters > New Parameters > Fan      
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13 Fan turn on temperature  °C 22 15 25 15 25 The inside temperature for fan to 

start to operate. The fan starts to 

run if inside temperature reaches 

the set temperature provided that  

- Humidity value is lower than the 

setpoint 

- There is No dew point alarm 

- Delta (∆t) temperature is higher 

then 0.1 oC  

- Outside temperature is lower 

then set value (Out Temp High F/C 

Operation)  

 
14 Fan turn off temperature  °C 28 24 32 22 38 The inside temperature for fan to 

stop to operate. While fan is 

operating and the inside 

temperature falls below this set 

temperature (meaning that the 

room is cool enough), then fan 

stops. 

 15 Selection of Fan type DC / AC  DC ✓ ✓ The fan type used in Free Cooling 

Sysytem 

16 Fan power type 55 W, …, 380 W W 190 W ✓ ✓ 
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 Fan speed (Night)  % 100 20 100 20 100 The fan power type used in Free 

Cooling Sysytem. 

This is the maximum fan speed in 

percent (%) according to the used 

fan spec provided that FCS Working 

mode is selected as  “ Night” in 

Operation Section of GUI 

 Fan speed (Daytime)  % 50 20 100 20 100 This is the maximum fan speed in 

percent (%) according to the used 

fan spec 

 

17 Indoor-outdoor delta temperature       

(ΔT) 

 °C 2 2 5 2 5 ΔT is the temperature difference 

between inside and outside. The 

fan starts to run with minimum fan 

speed when inside temperature 

exceeds 0.1 0C  the outside 

temperature (ΔT=0.1)  and speeds 

up directly proportional to ΔT. Fan 

reaches its maximum speed at  ΔT 

(set value).  All the other conditions 

for fan to operate must be 

provided. (See “Fan Turn On 

Temperature”) 
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18 Critical inside temp max fan speed, 

no AC 

ON / OFF °C 30 28 35 28 38 If there is no Mains and the inside 

temperature exceeds the critical 

level (defined  in this feature),  then 

the system operates fan at 

maximum speed. 

19 A/C phase fail fan speed 

 

 

 

HALF / MAX  HALF ✓ ✓ This feature provides the option to 

select the fan speed to half if mains 

fails. Thus it ensures to extend the 

duration of the backup system  

  

20 

 

Fan with work the A/C mode 

 

ON / OFF 

  

OFF 

  

✓ With this mode, after A/C started 

to run, according to 

indoor/outdoor temperature (ΔT), 

fan can run if it’s desired 

 

21 Fan Speed Unit LCD %RPM / DECIMAL  % RPM  ✓ The unit of fan speed shown on LCD 

could be selected as percent (%)  or 

numeric (Dec). 

 22 Humidity Algorithm 

 

ON / OFF  OFF  ✓ 
This feature is  to enable the 

adjusting the speed of the fan also 

according the humidity.Remember 

that the fan speed is related to 

temperature and humidity. 
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23 A/C Phase Fail Fan Off 

 

ON / OFF  OFF  ✓ If there is no Mains the system 

creates this alarm 

 A/C Fan count   

(Quantity of AC fans)  

 

 

 

       The number of the fans. Necessary 

for the system to create correct 

numbers of communication 

parameters. 

 Device Parameters > New Parameters > Mixed&Heater        

24 Mixed mode start temperature  °C 35 34 41 32 45 If the inside temperature exceeds 

this set temperature, the Mixed 

Mode starts and AC1&2 and fan 

operate together. 

 

25 Mixed mode fan turn off temp Set / Diff. °C 32 22 35 22 42 In mixed mode, the temperature 

for fan to stop when it cools the 

room below this temperature 

value 

 
26 Mixed mode A/C turn off temp  °C 25 24 32 20 36 If inside temperature exceeds 

Mixed Mode Start Temperature, 

A/Cs & fan run together to 

decrease inside temperature. 

While cooling inside this is the turn 

off temperature of A/C1. A/C2 

turns  off  ΔT degrees before A/C1. 

 
27 Heating method A/C / Heater  A/C ✓ ✓ The heater device is selected. 

 28 Heater turn on temperature  °C 10 2 10 2 10 The start temperature of the 

heater is adjusted. 
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29 Heater turn off temperature  °C 16 14 18 14 18 The stop temperature of the heater 

is adjusted. 

 30 If two heater is used, 

Delta temperature   (1)  

 °C 5   1 10 This is the temperature difference 

between the start (ON) 

temperature of  the 1st heater and 

the 2nd heater. 

 Device Parameters > New Parameters > Operation 

 

     

31 Fan off, outdoor temperature low ON / OFF °C 10   -20 10 If outside temperature falls below 

set value, operation of the fan and 

air flow stops.  

 32 Fan off, outdoor temperature high ON / OFF °C 45   40 60 If outside temperature exceeds to 

set value, operation of the fan and 

air flow stops.  

 
33 Fan off, Maximum indoor humidity ON / OFF °C 85 80 95 50 95 If inside humidity exceeds the set 

value, operation of the fan and air 

flow stops. With this mode, inside 

humidity value is held between 

desired range which devices can 

work decently.  
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34 Fan OFF Paramater enable in mixed 

mode 

ON / OFF  OFF  ✓ This feature is to enable “Fan OFF” 

and change the Fan OFF value in 

mix mode.   

Spec (*1) in mixed mode. If this 

feature is selected (ON), this means 

that while in mixed mode, fan will 

not turn off at (*1), will turn off at 

(*2). 

*1 Device Parameters > New 

Parameters > Mixed&Heater > 

Mixed Mode Fan Turn OFF 

Temperature 

*2 Device Parameters > New 

Parameters > Fan > Fan Turn OFF 

Temperature 

35 FCS Working mode  DAYTIME / NIGHT  NIGHT ✓ ✓ To reduce the noise caused by the 

fan at night , “FCS Day&Night Mode 

“  ensures the opportunity to 

decrease the fan speed  

determined in ” Fan Speed (Night) 

“ if  “Night” mode is selected here.  

 36 Start of the night   20:00 ✓ ✓ 
 The beginning and the end of the 

night is defined here.  Stop of the night   08:00 ✓ ✓ 

37 A/C 1, A/C 2 type 
STANDARD / 

INVERTER 
 INVERTER  ✓ 

The types of Acs are defined . 

 



FCS Free Cooling System User Manual 

Baran Elektronik Sistemleri San. ve Tic. Ltd. Sti. 

52 

38 Low batt alarm threshold  V -44 -46 -42 -46 -42 “Low Battery Alarm Threshold” is 

adjusted at the factory to  “-44 

VDC” for  supply voltage “-48 VDC” 

and adjusted to “22 VDC”  supply 

voltage “24 VDC”.  If the voltage of 

the batteries falls down to this 

value, the system sends a “Low 

Battery Alarm”  and stops the fan. 

 

 Low batt alarm threshold (1)  V +22 +21 +23 +21 +23 

         

39 High batt. alarm threshold  V -54 -60 -54 -60 -54 “High Battery Alarm Threshold is 

adjusted at the factory to  “-54 

VDC” for supply voltage “-48 VDC”, 

and adjusted to “27 VDC” for 

supply voltage “24 VDC”.  If the 

voltage of the batteries exceeds 

this value, the system sends “ High 

Battery Alarm” and stops the fan. 

 

 High batt. alarm threshold (1)  V +27 +27 +30 +27 +30 

         

40 Low temp. alarm threshold  °C 8 4 12 4 12 The minimum inside temperature 

value is determined the system to 

send alarm signal, “Low 

Temperature Alarm”  

This feature also needs an enabling 

in Device Parameters > New 

Parameters > Alarms > Low Temp 

Alarm (ON/OFF) 
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41 High temp. alarm threshold  °C 35 25 35 25 40 The maximum inside temperature 

value is determined the system to 

send alarm signal, “High 

Temperature Alarm”  

This feature also needs an enabling 

in Device Parameters > New 

Parameters > Alarms > High Temp 

Alarm (ON/OFF) 

 42 Very High temp. alarm threshold  °C 40   35 45 The very high inside temperature 

value is determined the system to 

send alarm signal, “Very High 

Temperature Alarm”  

This feature also needs an enabling 

in Device Parameters > New 

Parameters > Alarms > Very High 

Temp Alarm (ON/OFF) 

  Device Parameters > New Parameters > Alarms 

 

     

43 Low voltage alarm ON / OFF  OFF ✓ ✓ If the voltage of the batteries is 

lower than set value (*), system 

sends Low Voltage Alarm. * Device 

Parameters > New Parameters > 

Operation > Low Battery Alarm 

Threshold 
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44 High voltage alarm ON / OFF  OFF ✓  If the voltage of the batteries is 

higher than set value (*), system 

sends Low Voltage Alarm. 

 * Device Parameters > New 

Parameters > Operation > High 

Battery Alarm Threshold 

 45 Low temp. Alarm ON / OFF  ON ✓ ✓ If inside temperature falls below 

the set value (*), system sends 

“Low Temperature Alarm”. 

*  Device Parameters > New 

Parameters > Operation > Low 

Temp. Alarm Threshold 

 

 
46 High temp. Alarm ON / OFF  ON ✓ ✓ If inside temperature exceeds the 

set value (*), system sends “High 

Temperature Alarm”. 

*  Device Parameters > New 

Parameters > Operation > High 

Temp. Alarm Threshold 
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47 Very High temp. alarm ON / OFF  ON  ✓ If inside  temperature exceeds the  

set value (*), system sends “ Very 

High Temp Alarm”. 

 * Device Parameters > New 

Parameters > Operation > Very 

High Temp. Alarm Threshold 

 

48 Max humidity alarm ON / OFF  ON ✓ ✓ If inside humidity exceeds the set 

value (*), system sends Max 

Humidity Alarm. 

* Device Parameters > New 

Parameters > Operation > 

Maximum Humidity (Fan OFF) 

 

 

49 Dew-point alarm ON / OFF  OFF ✓ ✓ Dew point is calculated according 

to the instant temperature and 

humidity values. If this calculation 

results a dew point, then system 

creates this alarm 

50 Show FCS alarms on LCD ON / OFF  ON ✓ ✓ When this mode is ON, user can 

see all alarms on the screen. 
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51 Filter pressure alarm OFF     If filter pressure exceeds the set 

threshold value, system sends 

Filter pressure alarm. 

Filter pressure alarm threshold 

(Refer Section  4.6.1) 

 Filter pressure alarm threshold ON Pa 500 200 500 200 500 

       

52 Poor heating alarm ON / OFF  OFF ✓ ✓ This feature is to enable sending 

“Poor heating alarm” in case of the 

conditions are met in Section 4.6.1 

Alarms > Poor heating alarm  

53 Poor cooling alarm ON / OFF  OFF ✓ ✓ This feature is to enable sending 

“Poor cooling alarm” in case of the 

conditions are met in Section 4.6.1. 

Alarms > Poor cooling alarm  

 

54 

Fan power alarm ON / OFF  OFF ✓ ✓ This feature is to enable sending 

“Fan Power Alarm” in case of the 

conditions are met in Section 4.6.1 

Alarms > Fan Power Alarm  

55 Fan speed (RPM) alarm ON / OFF  OFF ✓ ✓ 
This feature is to enable sending 

“Fan speed (RPM) alarm” in case of 

the conditions are met in Section 

4.6.1 Alarms > Fan speed (RPM)  

56 A/C1 phase power alarm ON / OFF  OFF ✓ ✓ In case of absence of  A/C1’ mains, 

system sends A/C1 Phase Power 

Alarm. 
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57 A/C2 phase power alarm 

 

 

ON / OFF  OFF ✓ ✓ In case of absence of  A/C1’ mains, 

system sends A/C1 Phase Power 

Alarm. 

  ON all alarms   off all alarms      Used to switch all alarms ON or OFF 

position in one thick 

 Device Parameters > New Parameters > Date & Time, NMS 

Settings 

 

    
 

58 Date & Time, NMS Settings      Date&Time settings are adjusted 

here. 

 
59 Automatic Summer-Winter Time      

 

60 Send the NMS data in case of event & 

alarm 

ON / OFF  ON  ✓ This feature is to enable sending 

NMS data in case of event & alarm 

occur . 

 

 

61 The period of the sending NMS data  Minute 1440  ✓ The period of the sending NMS 

data is defined. 

 Device Parameters > New Parameters 

> Generator Control 

 

The  following features of “Diesel Generator” are designed especially for free cooling in OFF-GRID SITES also fits 

every type of sites. Refer to explanation and scheme 10-11 in Section  4.6.2.1 
62 DG Control ACTIVE / PASSIVE  PASSIVE ✓ ✓ Enables Diesel Generator option. 

63 DG Operation Time  hh:mm:ss 04:00:00 ✓ ✓ If it is not expected the generator  

to operate too much in off-grid 

sites because of the fuel 

consumption, the operation time 

of the generator could be  limited. 
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64 DG Start Low Battery (DC) Threshold  V -44 ✓ ✓ Generator runs to charge the 

batteries if hte voltage falls down 

to threshold level . When it reaches 

the required level, generator stops 
65 DG Start Low Temperature Threshold  °C 8 ✓ ✓ If inside temperature falls down to 

threshold level, generator starts 

and runs A/C (for heating). 

66 DG Start High Temperature Threshold  °C 40 ✓ ✓ If inside temperature exceeds the 

threshold level in off-grid sites , 

generator starts and runs A/C. 

 

Note: 

(1) This feature is used for + 24 VDC supply value and two phase systems. 
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DIESEL GENERATOR OPTION (OFF GRID SITES) 

In many off-grid sites with diesel generator, there is a common principle of operating the 

cooling  system algorithm shown as flow chart in scheme 7 -8 .  

 

1. If the battery voltage level decreases below a threshold level then DG starts for to charge 

the batteries. DG stops when the required battery voltage level is achived (Turn ON DG If 

Battery Voltage (VDC) is lower than…) 

2. If the inside temperature level exceeds  a threshold level then DG starts operate the air 

conditioners. DG stops when the required inside temperature level is achived. (Turn ON 

DG If Temperature is higher than …) 

3. If the inside temperature level decreases below  a threshold level then DG starts operate 

the air conditioners for heating. DG stops when the required inside temperature level is 

achived. (Turn ON DG If Temperature is lower than…) 

4. If it is intended to limit the DG operation time because of the fuel consumption then the 

operation time can be adjusted with “DG Non-stop Running Time” command 
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Scheme 7  : Operation Algorithm of FCS in  Off-Grid Sites with Diesel Generator 
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Scheme 8  : Operation Algorithm of FCS in  Off-Grid Sites with Diesel Generator (Detailed) 

 

Abbreviations 

time                : Actual Operation time of Diesel Generator (DG) 

tdgwrk            : Max. permitted operating time of DG, set in GUI as " DG Working Time"   

Vbat                : Actual Battery Voltage  

Vdgenlwbat   : Min. permitted battery voltage(the voltage level that DG to start running at this  

voltage level thus charging the batteries) set in GUI as "DG Start Low Battery   Threshold) 

Ti                      : Actual Inside Temperture 

Tdghigh           : The max. permitted inside temperature (the temperature value that DG to start   

running to start the airconditioner(s) for cooling the room. This parameter is set in GUI as "DG Start 

High Temperature Threshold" 

DG                     : Diesel Generator  

 

 

 

 

 

 

 

 

 

 

 



FCS Free Cooling System User Manual 

Baran Elektronik Sistemleri San. ve Tic. Ltd. Sti. 

62 

5. PERIODIC MAINTENANCE  
 
The only part of the free cooling system needs to be periodically replaced is the filter. In the site visit, 
other parts including fan should be checked. 
 
Timeframe : It depends on the environmental and climate conditions of the site’s location. 
 
The site visit may be planned related to the filter cloggines alarm received from digital differential 
pressure sensor or analog pressure switch. 
 
 

5.1. Filter Replacement  

 
 
 

1. Turn OFF free cooling fan by switching to air conditioners.  
2. Remove the filter cover by unscewing screws as shown below. 
3. Slide out two filters . Be careful, it may cause injury if it drops down.  

 

 
4. After removing the filters , 

 
The G2 filter, 

- If you have a spare, replace with new one,  
- If you don’t have, wash it and get it dried well. If you place it before well dried, water drops 

may cause defect on fan motor and other equipments in the room. 
 
The G3 filter  
 

- Unscrew 4 screws located on the corners of the frame 
- Seperate two interlaced wings  
- Change the fiber 
- Close the wings by interlacing well 
- Screw 4  screws 
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5. Place two filters in the slot. 
6. Replace the filter cover and fix by screwing the screws. 

 
 

5.2. Filter Replacement for VANDAL PROOF TYPE FAN BOXES 

 
 

Paying attention to followings, unscrew the  philips head screws  indicated with arrows.  

 

 

 

 

1. The screws are positioned on the left/right of the outer hole axis② when fully fastened. 
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2. When it is started to be unscrewed, the head of the screw moves to the axis of the outer 

hole①. 
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3. While unscrewing, it is advised not to completely detached the screw from its hole for the 

easiness of the next steps. Stop unscrewing when the filter fastening bar gets free to be 

taken out easily. 

 

4. Slide the filter fastening bars right/left and remove them. 
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5. Remove the filter plate grill. Be carefull not to drop otherwise heavy parts may damage and 

you may get injured. 

 

 

 

 

 

 

 

 

 

 

6. After removing the filters , 

 
The G2 filter, 
 

- If you have a spare, replace with new one,  
- If you don’t have, wash it and get it dried well. If you place it before well dried, water drops 

may cause defect on fan motor and other equipments in the room. 
 
The G3 filter  
 

- Unscrew 4 screws located on the corners of the frame 
- Seperate two interlaced wings  
- Change the fiber 
- Close the wings by interlacing well 
- Screw 4  screws 
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7. Place two filters in the slot. 

8. Replace filters back performing vice versa the steps you have done for removing the filters. 

9. The Replacement Order of the Filters: 
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6. MAINTENANCE - REPAIR 
 

 
! SWITCH OFF the energy/electricity   of fan box and control unit before starting maintenance or repair!   
It may cause mortal injuries, please be sure that energy/electricity is SWITCHED OFF 
 

6.1. Removing Fan (Motor)  

 
 

1. Remove the air inlet grill and the cable protection cap by unscrewing the screws lightened with 
yellow arrows. ① 

2. Lay down the air inlet grill and disconnect the connectors water float sensor (optional) ② 
3. Unscrew two screws on the fan plate and remove them③ 
4. Slide out the fan plate until half④ 
5. Before releasing the fan plate, disconnect the connectors located at the bottom left of the 

plate.⑤ 
6. Push the security pin located inside the fan plate  2-3 mm upward by bending forward your 

hand as shown with yellow arrow⑥ 
7. Please be carefull not to damage the fan flange located under the fan. Any strike may damage 

the precise distance between the fan and the flange.This may cause important defects and 
damages.Release the fan plate from the slot with two persons.⑦ 

 
 

 
 
 
 
 

8. Leave the fan plate smoothly on a flat place. Fan staddle is fixed to fan plate with 6  bolts-nuts 
(3 left,3 right). Seperate the fan staddle and the fan plate by removing the bolts.⑧ 
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9. Remove the fan cable and the connector from the fan staddle, release fan by unscewing 4 
screws at the top of the staddle. ⑨ 

 

 

6.2. Removing The Digital Differential Pressure Sensor / Analog Pressure Switch  

  
 In outdoor models, they can be reached via two ways whether from top or bottom. 
  
 Reaching from the top; 
 

- First perform the steps ①②③④⑤⑥⑦ in Removing Fan (Motor) 
 
 
Reaching from the bottom; 
 

- Remove the filters as in filter replacement  
-  
Now, proceed as follows, 

 
 

 
For Removing The Digital Differential Pressure Sensor 
 

10. Pressure sensor is placed on a plate located at the left inside the fan box. Check the location 
of the pressure sensor⑩ 

11. Remove the tube of the pipe labelled as “OUT” smoothly. Don’t forget that the pipe labelled 
as “IN” should always be empty.⑪ 

12. Disconnect the connector⑫ 
13. Remove the digital difference pressure sensor by unscrewing the screws, 2 right and 2 left.⑬ 
 

 
For Removing The Analog Pressure Switch 

 
10. Pressure switch is placed on a plate located at the left inside the fan box. Check the location 

of the pressure sensor.⑩ 
11. Remove the tube of the bottom (grey) pipe smoothly.The upper pipe should always be 

empty⑪ 
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12. To disconnect the cable connection of the pressure switch, unscrew the screw on the top 
cover, release cover and remove the spade terminals of the cable carefully.⑫ 

13. Remove the pressure switch by unscrewing the screw on the corners.⑬ 
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7. TROUBLESHOOTING 

 
 In Free Cooling Systems, there are information, error, alarm and fault leds(indicators)  on 
control unit, GUI and web interface. 
 
 The descriptions of the colored leds and finding the solution (if they point an error or a faul) 
are explained below.  

 
 
Information Leds 

 

    
INFO LEDS LED COLOR DESCRIPTION 

AIR 
CONDITIONER 1 

       GREEN 
Air conditioner 1 is running. 

 
NOT 
LIGHTING 

Air conditioner 1 is not running. 

AIR 
CONDITIONER 2 

       GREEN 
Air conditioner 2 is running. 

 
NOT 
LIGHTING 

Air conditioner 2 is not running. 

DC FAN 

 
 

GREEN 
DC Fan is running. 

 
NOT 
LIGHTING 

DC Fan is not running. 

AC FAN 
 

        GREEN AC Fan is running. 

 
NOT 
LIGHTING 

AC Fan is not running. 

FAN HALF 
SPEED 

 ORANGE 

Fan is running at half speed because Mains is lost. 
(The feature  in Fan Menu  “ If Mains Lost, 
Operate Fan   at Max/Half Speed” must have 
been selected as  HALF for this led to be active.” 

 
NOT 
LIGHTING 

Fan is running at max. speed. 

DIESEL 
GENERATOR 

       GREEN Diesel Generator is running. 

 
NOT 
LIGHTING 

Diesel Generator is not running. 

 
 
 
 
 
 
Error And Fault Leds 
 



FCS Free Cooling System User Manual 

Baran Elektronik Sistemleri San. ve Tic. Ltd. Sti. 

72 

ERROR 
AND 

FAULT 
LEDS 

LED 
IDENTIFYING THE 

PROBLEM 
SOLUTION 

GENERAL 
ALARM 

 
 

      RED 

This led lights up if 
any of the 15 
standart alarms  
gets active. 

First it should 
be defined  
which alarm 
causes the 
general alarm 
led to light 
up.This may 
be defined in 
3 different 
ways. Then 
the problem 
of the real 
alarm should 
be fixed. 

Control Unit LCD : 
The source of the 
alarm could be  
seen on the 4th 
line of LCD.( For 
this, “Show Alarms 
On LCD” feature in 
Alarm Menu of 
GUI/Web Interface 
shoul have been 
enabled. 
Otherwise, alarms 
can’t be seen on 
LCD 
 

The Alarms 
in Alarm 
menu of 
GUI/Web 
Interface 
should NOT 
be Disabled 
for this 
feature to be 
active. 

GUI/Web 
Interface: In the 
main screen, it is 
indicated with RED 
led. 

  
NOT 

LIGHTING 

No Alarm 
 

   

FILTER 
ALARM 

 

 
 RED 

Filter cloggness is 
above the 
threshold level 

Filter needs 
to be 
replaced or 
cleaned. 

  

 
 NOT 

LIGHTING 

Filter cloggness is 
below the 
threshold level.  

   

FAN 
ALERT 

 RED 

Fan hız alarmı. 
Fanın çalışması için 
tüm şartlar 
olmasına rağmen 
fan dönmüyor. 
Fan speed alarm. 
The fan is not 
turning in spite of 
every condition for 
fan to is present.  

“Clear Instant 
Alarms “ 
command is 
performed in 
Tools menu 
of GUI/Web 
Interface.  

If the alarm is not 
cleared and the fan 
is not turning  call 
the technical 
service of Baran 
Technology. 

 

 
 NOT 

LIGHTING 

No problem 
related to fan 
speed. 

   

ERROR 
AND 

LED 
IDENTIFYING THE 

PROBLEM 
SOLUTION 
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FAULT 
LEDS 

SILENT 
MODE 

     
GREEN   

“Night Mode is 
active. Fan speed is 
decreased to Night 
Speed 

   

 
NOT 

LIGHTING 

Fan is running at 
daytime speed. 
 
 

   

MAINS 1 

     
GREEN 

The Mains of the 
A/C1 (air 
conditioner control 
module 1) is 
present. 

   

  
RED 

The Mains of the 
A/C1 (air 
conditioner control 
module 1) is lost 

Breakers and 
other 
components 
of Mains 
should be 
checked 

If there is no 
problem with 
Mains, then air 
conditioner control 
module might  be 
defected 

 

MAINS 2 

      
GREEN 

The Mains of the 
A/C2 (air 
conditioner control 
module 2) is 
present. 

   

 
 RED 

The Mains of the 
A/C2 (air 
conditioner control 
module 2) is lost 

Breakers and 
other 
components 
of Mains 
should be 
checked 

If there is no 
problem with 
Mains, then air 
conditioner control 
module might be 
defected 
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8. SPARE PARTS  No
Spare 

Part No
Name Brand Model Note Picture

1 SPDB001 Panel Board (Metal) Baran MDB-10

2 SPDB002

Free Cooling 

Control Module 

(Unit)

Baran FCCMV07

3 SPDB003
Air Conditioner 

Control Module 
Baran ACCMV10

4 SPDB004

InsideTemperature  

and Humidity 

Sensor (with cable)

Baran STH-10
Cable Length : 1 m   

4x0,22 LiYY Cable

5 SPDB005

Outside 

Temperature 

Sensor (with cable)                       

Baran STX-10
Cable Length : 1,5 

m   2x0,22 Li2YY 

Cable

6 SPDB006
Circuit Breaker 

(Panel Board)
Siemens FSW16A 10 A

7 SPDB007
Circuit Breaker 

(Panel Board)
Siemens FSW01A 01 A

8 SPDB008

InsideTemperature  

and Humidity 

Sensor Cable (with 

conn.)

Baran STHC-900
Cable Length : 9 m   

4x0,22 LiYY Cable

9 SPDB009

Outside 

Temperature 

Sensor Cable (with 

conn.)

Baran STXC-900

Cable Length : 8,5 

m   2x0,22 Li2YY 

Cable

10 SPB001

Digital Differential 

Pressure Sensor 

Tube

EuroFlex SDP-H140

Diameter :6mm x 4 

mm    Length :1,4 

m

11 SPB002 Fan Box Baran FBX208CO/ VP

12 SPB003 Air Inlet Grill Baran ATI-35

13 SPB004 Air Outlet Hood Baran ATO-30 / VP
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14 SPB005 G2 Filter ( Black ) MGT BR-KF0-450/535/10-G2

15 SPB006
G3 Filter Fiber 

Changable ( White )
Başak FG3C-30

16 SPB007 Water Float Sensor N/A N/A

17 SPB008
Changable Filter 

Fiber
Baran FBR-30 90 cm x 55 cm

18 SPB009

Digital Differential 

Pressure Sensor 

(with cable)

Baran SDP-10

Cable Length:65 

cm   4x0,22 LiYY 

Cable

19 SPB010 Fan
GP 

Motor RB3E355/120C

20 SPB011 Fan Control Module Baran DFM12 For AC fan

21 SPB012 Fan Control Module Baran DFM12 For DC fan

22 SPB013 Fan Flange Baran FLNG-C30

23 SPB014 Handle (Big) Atos Kilit TK09.35

24 SPB015 Handle (Small) Atos Kilit TK19.35

25 SPB016

Digital Differential 

Pressure Sensor 

Cable (with conn.)

Baran SDP-C65

Cable Length :65 

cm   4x0,22 LiYY 

Cable

26 SPB017 Pako Lock N/A N/A

27 SPB018 Membran Baran PLSTK-10

28 SPB019 Louver Baran LVR-30

29 SPB020 Conic bolt(Yellow) N/A N/A

30 SPB021 Square Grid N/A N/A

31 SPB022
Aluminium Label 

(ID)
Baran APLT-30

32 SPB023 Fan Box Legs N/A N/A
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9. TERMS OF WARRANTY 
 

FCS device is not covered by warranty in the following cases 

The valid of this guaranty is 2  years 

Wrong connection failures 

Any damage in case of a lightning strike 

Any damage in case of any ground failure 

Any damage when mains voltage and DC supply voltage are not in the operation range 

Any damage that may occur as a result of exposure to throwing, hitting, crushing etc. 

When service and maintenance performed by unauthorized persons 

When the mounting is made by unauthorized persons 

Opening the cover of the device when it’s still under the warranty 

 


